Urgent action required with Cobham Sailor FBB and FleetOne

18 September, 2018 Inmarsat FleetBroadband Range

Inmarsat annouced a new Multi-Voice feature to the Fleet One, FleetBroadband 150, 250 and 500 terminals. It is currently available globally and older Cobham terminals urgently require a firmware update to ensure that the IP handset(s) ring on incoming calls.

If you have one of the terminals listed below and it is not in 1.25 firmware version, you MUST update your firmware immediately to avoid incoming call issues.

Download the latest firmware HERE

Affected terminals/firmware
Cobham (Thrane & Thrane) terminals: FleetBroadband 150, 250 and 500, and Fleet One.